Go To Bottom

Printable Version  
Author: Subject: 4E-FTE Battery light barely coming on
1.3L Turbo Tercel
TO Newbie
*


Avatar


Posts: 3
Registered: 8-3-2015
Location: Vancouver WA
Member Is Offline


[*] posted on 9-2-2017 at 09:51 PM
4E-FTE Battery light barely coming on


Hey guys!
So lately I've been noticing "early in the morning, I work at 4am" That under high rpms a good 5000+ the battery lights faintly comes on, I've also been noticing I'm only boost to 6 tops 7psi, I don't know if that's my ebay boost gauge or because the spark plugs aren't getting enough juice to ignite the fuel, I do have a cigarette lighter voltmeter plug in and it drops form 14.6v to 14.5v when the light starts dimly showing up

Any input or suggestions are much appreciated!

I have considered a new alternator but I don't know if I want to spend the $70 yet if its not the problem

Thanks! :waving:
-Tyler




96 Tercel with Glanza swap
T25 Turbo upgrade
Top Mount
Paseo sway bar, brakes and gauge cluster swap

View user's profile View All Posts By User
mulberry
TO Crew
******




Posts: 3342
Registered: 9-1-2005
Location: Florida
Member Is Offline

Mood: No Mood

[*] posted on 11-2-2017 at 02:11 PM


Check your grounds, then have the battery and alternator checked. Then go from there
View user's profile Visit user's homepage View All Posts By User
Italianjoe1
Junior TO Member
***


Avatar


Posts: 234
Registered: 12-3-2013
Location: Miami, FL
Member Is Offline


[*] posted on 11-2-2017 at 06:35 PM


Sounds like a ground issue, the main engine ground is part of the circuit for that charging indicator, and can affect other PCM things like boost if it's still controlled by the stock computer.

If your voltage at the outlet is 14, there's no reason the light should be on at all. Gotta troubleshoot the wiring first.
View user's profile View All Posts By User
1.3L Turbo Tercel
TO Newbie
*


Avatar


Posts: 3
Registered: 8-3-2015
Location: Vancouver WA
Member Is Offline


[*] posted on 8-3-2017 at 02:25 PM


Thanks for the info guys, so I have a ton of grounds, my alternator was tested and it's good and I just got a new battery so all that is good from what I know unless my grounds are rotted out... BUT Now the actual dash lights are flickering and going dim -_-



96 Tercel with Glanza swap
T25 Turbo upgrade
Top Mount
Paseo sway bar, brakes and gauge cluster swap

View user's profile View All Posts By User

  Go To Top

Powered by XMB 1.9.11
XMB Forum Software © 2001-2010 The XMB Group